
Sphinx Search Ultimate 2.3.2

Getting Started
Welcome to the Sphinx Search Ultimate Documentation. Whether you are new or an advanced user, 
you can find useful information here. First of all we recommend to check the following links: 

How to install extension

How to install extension
1. Login to Magento backend.
2. Go to System > Tools > Compilations. If Compiler Status is Enabled, disable the compilation by 

clicking the button Disable in the upper right corner.
3. Backup your store database and web directory.
4. Download extension from your Personal Account.
5. Unzip the extension locally.
6. Copy contents of the folder step1 to the root directory of Magento store.
7. Copy contents of the folder step2 to the root directory of Magento store.
8. Completely clear the site cache. Go to System > Cache Management. Click button Flush 

Magento Cache. If you want to clear the cache manually, you need to remove a folder /var/cache 
at the server.

9. Logout from Magento backend and login again.
10. Go to Search > Manage Search Indexes and configure Product index.
11. Go to System > Index Management. Run reindex of the Search Index.
12. Go to System > Configuration > Mirasvit Extensions > System, at form Installed Extensions

press the button Run validation tests for all extensions for check extension installation and 
configuration.

13. If compilation was enabled before installation, you need to run recompilation process to enable 
compilation. Go to System > Tools > Compilation and click on Run Compilation Process.
If you did not disable compilation and store is down after installation, follow the link and make 
next steps to recover the store.

14. If necessary adjust css styles to fit your store's frontend theme. See how to change Autocomplete 
styling

How to upgrade extension
To upgrade extension follow next steps: 

1. Login to Magento backend.

http://mirasvit.com/downloadable/customer/products/
http://mirasvit.com/doc/common/recover


2. Go to System > Tools > Compilations. If Compiler Status is Enabled, disable the compilation by 
clicking the button Disable in the upper right corner.

3. Backup your store database and web directory. If you have customizations, please, create a 
separate backup of app/code/local/Mirasvit before upgrading to the new version.

4. Download new extension package from your Personal Account.
5. Unzip the extension locally.
6. Temporary disable extension. Check Temporary Disabling.
7. Copy contents of the folder step1 to the root directory of Magento store.
8. Copy contents of the folder step2 to the root directory of Magento store.
9. Completely clear the site cache. Go to System > Cache Management. Click button Flush 

Magento Cache. If you want to clear the cache manually, you need to remove a folder /var/cache
at the server.

10. Logout from Magento backend and login again.
11. If compilation was enabled before upgrade, you need to run recompilation process to enable 

compilation. Go to System > Tools > Compilation and click on Run Compilation Process.
If you did not disable compilation and store is down after upgrade, follow the link and make next 
steps to recover the store.

12. If necessary adjust css styles to fit your store's frontend theme.

Extension Disabling

Temporary Disabling

To temporary disable extension please follow the next steps: 
Disable Compilation Mode (if enabled).
Remove following files: 

app/etc/modules/Mirasvit_SearchIndex.xml
app/etc/modules/Mirasvit_SearchSphinx.xml
app/etc/modules/Mirasvit_SearchLandingPage.xml
app/etc/modules/Mirasvit_SearchAutocomplete.xml
app/etc/modules/Mirasvit_Misspell.xml

If you have only one extension from Mirasvit installed, remove following file: 
app/etc/modules/Mirasvit_MstCore.xml

Login in to Magento back-end and refresh site cache (if enabled).

Extension Removing

To uninstall extension please follow the next steps: 
Disable Compilation Mode (if enabled).
Remove following files: 

app/etc/modules/Mirasvit_SearchIndex.xml
app/etc/modules/Mirasvit_SearchSphinx.xml

http://mirasvit.com/downloadable/customer/products/
http://mirasvit.com/doc/common/recover


app/etc/modules/Mirasvit_SearchLandingPage.xml
app/etc/modules/Mirasvit_SearchAutocomplete.xml
app/etc/modules/Mirasvit_Misspell.xml

If you have only one extension from Mirasvit installed, remove following file: 
app/etc/modules/Mirasvit_MstCore.xml

Login in to Magento back-end and refresh site cache (if enabled).
Remove following folders: 

app/code/local/Mirasvit/SearchIndex
app/code/local/Mirasvit/SearchSphinx
app/code/local/Mirasvit/SearchLandingPage
app/code/local/Mirasvit/SearchAutocomplete
app/code/local/Mirasvit/Misspell

Remove templates and layouts files of extension from your theme folder. List of such files can be 
collected from files in the extension package.

How to translate extension interface
1. On your server copy files: Mirasvit_SearchIndex.csv, Mirasvit_Misspell.csv, 

Mirasvit_SearchAutocomplete.csv from the folder app/locale/en_US/ to the folder 
app/locale/[language_code]/. List of codes for different languages you can find here: List of ISO 
639-1 codes.

2. Open the new file and translate the text in the right column. Don't change the text in the left 
column.

3. Save the translated file and clear magento cache.

A few examples of language codes: 
Language Code Description
en_US English (United States)

en_GB English (United Kingdom)

nl_NL Dutch (Netherlands)

de_DE German (Germany)

de_CH German (Switzerland)

fr_FR French (France)

fr_CA French (Canada)

hi_IN Hindi (India)

es_ES Spanish (Spain)

pt_BR Portuguese (Brazil)

pt_PT Portuguese (Portugal)

Change Log

http://en.wikipedia.org/wiki/List_of_ISO_639-1_codes
http://en.wikipedia.org/wiki/List_of_ISO_639-1_codes
https://mirasvit.com/doc/extension_searchultimate/current/changelog


Change Log

Search Spell Correction [mirasvit/extension_misspell]

1.2.11

(2018-07-27) Fixed 
Persist URL parameters when redirecting with Search Spell-Correction

1.2.10

(2018-06-13) Fixed 
Fallback issue with space after short search term

1.2.9

(2017-07-27) Fixed 
Lowercase compared with Spell Correction words

1.2.8

(2016-12-01) Improvements 
Documentation update

1.2.7

(2016-09-12) Improvements 
Do not perform spell correction if search term has internal synonym

1.2.6

(2016-07-05) Improvements 
NL translation

1.2.5

(2015-06-29) Features 
Initial stable release

Search Autocomplete [mirasvit/extension_searchautocomplete]

1.2.14



(2018-09-12) Features 

Added search autocomplete profiler

Fixed 
Added support of Amasty Hide Price
Added validator for autocomplete block in Hide Price block types

1.2.13

(2018-05-31) Fixed 
Fix for display in-stock configurable products thumbnail

Features 

Added Infortis brands search index

1.2.12

(2017-02-01) Features 
added functionality to manage keyboard hide delay

1.2.11

(2017-12-12) Improvements 
For configurable products show a thumbnail of the product which is in-stock (#7)

1.2.10

(2016-09-04) Fixed 
Fix on mobile view - search autocomplete placeholder hides when close virtual keyboard

Features 
Ability to choose search indexes as filters for the search autocomplete

1.2.9

(2016-08-01) Fixed 
Correctly count number of items visible in the search autocomplete dropdown

Improvements 
Substitute the query separator for ajax request dynamically

Features 
Validate extension's CRC values

1.2.8



(2016-07-07) Fixed 

Move function implementation from global context to block

1.2.7

(2016-07-05) Improvements 
NL translation

1.2.6

(2016-06-24) Improvements 
Search results for index Mirasvit Gift Registry
Updated cateogory template

1.2.5

(2016-03-28) Fixed 
Fixed possible issue with ajax controller (compare 2 queries)

1.2.4

(2016-03-10) Fixed 
Fixed an issue with wrong all results url (without current category)

1.2.3

(2016-02-17) Fixed 
Updated dependencies for MstCore module
Fixed an issue with empty store parameter in ajax request

1.2.2

(2016-01-28) Fixed 
Fixed an issue with cms block template
Fixed an issue with search term highlighting

Improvements 
Added conflict validator for extension Webdziner_Ajaxsearch

1.2.1

(2015-05-01) Fixed 
Fixed an issue with higlighter (char "&")
Fixed an issue with MSRP prices
Fixed an issue with filtering autocomplete result by selected category

Improvements 



Added ability to use filter by attribute in the default theme
Added built-in validator
Added styles for RWD theme

Search Sphinx [mirasvit/extension_searchsphinx]

2.3.47

(2018-12-06) Fixed 
improved conflicts validator [#124]

2.3.46

(2018-12-03) Fixed 
made synonyms store-specific [#80]
search by tags indexing issue

2.3.45

(2018-11-08) Fixed 
Synonyms results have search weight = 0

2.3.44

(2018-11-06) Fixed 
404 to search notice issue

2.3.43

(2018-10-30) Fixed 
getSize issue after group by

2.3.42

(2018-10-25) Fixed 
Issue with tags indexing

2.3.41

(2018-10-17) Fixed 



Issue with search by custom options

2.3.40

(2018-10-17) Features 
Added "Minimal Query Length" option to Validate Search Results

2.3.39

(2018-10-16) Fixed 
getSize() issue after group by
wrong link in validate search results

2.3.38

(2018-09-27) Fixed 
Compatibility with PHP7.2

Features 
Added search autocomplete profiler

Documentation 
Info about date modifiers for Wordpress URL template

2.3.37

(2018-08-14) Improvements 
Ability to use date modifiers to form Wordpress blog post URL

Fixed 
changed error message label to info

2.3.36

(2018-07-25) Fixed 
fixed generating sphinx config file issue

Documentation 
Replace words in search query

2.3.35

(2018-07-20) Improvements 



added sphinx3.* support
improved installation validator functionality (better check for conflicts)

Fixed 
changed status caption in validator search results
fixed negative search weights support for sphinx engine mirasvit/extension_searchsphinx#53

2.3.34

(2018-06-14) Fixed 
Issue with search by child products attributes

2.3.33

(2018-06-14) Fixed 
search by product ID issue

2.3.32

(2018-03-09) Fixed 
Remove all non alphanum chars from sphinx bin path

2.3.31

(2018-02-07) Improvements 
Addition validator message regarding product visibility in search results
Improved search algorithm for External Mode (Sphinx Engine)

Fixed 
Fix error 'headers already sent'

2.3.30

(2018-01-11) Improvements 
Show validation message for conflict with the module 'Simtech_Searchanise' 
mirasvit/extension_searchultimate#5

2.3.29

(2018-01-10) Improvements 
Improve validator message



2.3.28

(2017-11-07) Fixed 
Properly index searchable data

2.3.27

(2017-10-30) Feature 
Add seacrh terms export

Improvements 
Make external mode more accurate

2.3.26

(2017-09-04) Fixed 
Inaccurate weight to items that do not match the search word in external mode

Improvements 
Added stopword dictionaries for German, French, Dutch

2.3.25

(2017-04-26) Fixed 
Fix error 'Headers already sent' caused by function '404 to search'

2.3.24

(2017-04-21) Fixed 
Fix module Mage Configurable Swatches does not work on search result pages when our 
extension used (affects all).

Improvements 
Troubleshoot. Fix problem with the Mage Configurable Swatches module.
Troubleshoot. Fix conflict with Mana Filters extension.

2.3.23

(2017-02-15) Fixed 
Escape sphinx query

Improvements 
Improve performance for single result redirect

2.3.22

(2017-01-24) Fixed 



Fix singularize issue in Dutch language (affects all)

2.3.21

(2016-11-02) Fixed 
Compatibility with Magento 1.9.3.1
Use product search weight from default scope if it empty at a store scope

2.3.20

(2016-11-02) Documentation 
Documentation updates

2.3.19

(2016-11-02) Fixed 
Wrong search weight calculation for products

2.3.18

(2016-10-31) Feature 
Ability to select ignored categories for the search index

Fixed 
Wildcard exceptions ignored if wildcard suffix or prefix mode are used (affects all)

2.3.17

(2016-10-13) Fixed 
Correctly use translation method

2.3.16

(2016-10-11) Fixed 
Fix problem with search terms when flat catalog product enabled

Improvements 
Performance improvement for single result redirect

2.3.15

(2016-08-18) Improvements 
Improve search speed script

Fixed 
Fix CRC issue for search index files



2.3.14

(2016-08-10) Fixed 
Fix for php 7 constructor method name same as class name

Improvements 
Surface improvements for the indexation process

2.3.13

(2016-08-04) Improvements 
Scope label for settings at the search indexes
Improve search for index Mirasvit Gift Registry
Change column type for search index field "title"

2.3.12

(2016-08-01) Improvements 
Show debug info for External Sphinx Engine
Stop searchd using its own command and use URL of default store

Improvements 
Validate extension's CRC values

2.3.11

(2016-07-13) Fixed 
Fixed an issue with mb_strtolower

2.3.10

(2016-07-05) Improvements 
NL translation

2.3.9

(2016-07-05) Fixed 
Check Giftr block existence
Fixed a potential XSS issue with m_test_search_speed.php

2.3.8

(2016-06-24) Improvements 
New search index for Mirasvit Gift Registry

2.3.7

(2016-06-21) Fixed 



Properly process multibyte UTF-8 characters

2.3.6

(2016-06-13) Fixed 
Fix issue with the search queries that contain the word 'as'

2.3.5

(2016-05-31) Improvements 
Enable morphology search for External Sphinx Engine when the wildcard search is enabled

2.3.4

(2016-05-28) Fixed 
Convert store ID to array only for Sphinx Client
Rebuild "Search terms" section and improve performance

2.3.3

(2016-05-23) Improvements 
Added ability to use custom attributes in search by categories

2.3.2

(2016-05-13) Features 
Added ability to filter search results by relevance

Improvements 
Improved query builder performance (stopwords)
New search index for Blackbird ContentManager
Compatibility with the version of Magento 1.4.1.1
Added bundled product to primary product search index
Added store code to multi-store search results configuration
Extended list of conflicted extensions for validator (Activo/CatalogSearch, 
Netzarbeiter/GroupsCatalog2)

Fixed 
Fixed an issue with dublicating queries at Catalog / Search Terms
Fixed an issue with enclose relevance column
Fix problem with search report (affects from 2.3.2.100)
Fixed issue with "." in search terms (sphinx mode)
Update composer.json (requirements)
Fixed an issue with Undefined offset for entity custom weights
Fixed an issue with wrong quote in sql query, when option "Push out of stock products to bottom" 
is enabled


